Performance issue

Performance issue Search Search

SMS & MMS Technical Forum » NowSMS Support - SMS Issues (Product Support Only) » Archive through April 11, 2011 » Performance issue « Previous || Next »
Author Message
Alex Kaiser
Frequent Contributor
Username: Alex_k

Post Number: 187
Registered: 07-2006
Posted on Friday, March 25, 2011 - 01:47 pm:   

Hi Des,

We have generated 400k of .LCK files into queue folder and server experienced uncontrollable CPU peaks and very slow overall system performance. Ashot is right you have to revise generation of segmented messages, .LCK must be deleted when last part of a message leaves gateway.

Regards,
Alex K
Des - NowSMS Support
Board Administrator
Username: Desosms

Post Number: 3051
Registered: 08-2008
Posted on Friday, March 25, 2011 - 02:36 pm:   

Hi Alex,

Agreed that 400K of these files is a problem. We did used too delete immediately if there were no more parts of the message left in our queues, but this caused an issue if another system had a delay or pause between segments.

So we put in a delayed delete, but I think the interval is under 60 seconds.

That makes me think something else is going on.

You might want to look at the update that was posted today, as engineering claims to have streamlined the delayed delete logic.

The update is at http://www.nowsms.com/download/nowsms20110321.zip.

I will also investigate wha this delayed delete time interval is, as if the problem persists we need to determine what causes these files to build up on your system, as we can never recreate it.

--
Des
NowSMS Support

--
Des
NowSMS Support
Alex Kaiser
Frequent Contributor
Username: Alex_k

Post Number: 188
Registered: 07-2006
Posted on Friday, March 25, 2011 - 11:33 pm:   

Hi Des,

We've made some tests and seem that new version (we're using 2010.09.21) has problems with HTTP submission. Your testing tool shows around 220 sms/sec and some strange timeout errors, but our build has speed 780 sms/sec. Please check.

Regards,
Alex K.
Alex Kaiser
Frequent Contributor
Username: Alex_k

Post Number: 191
Registered: 07-2006
Posted on Sunday, March 27, 2011 - 11:57 am:   

Hi Des,

Our test environment was broken, please forget about results. I'll update you soon.

Regards,
Alex K.

Login Login / Register Search Search   Home Home
Logout Logout Topics Topics Search Last 1|3|7|30 Days   Previous Page Previous Next Next Page